You may be seeing this page because your web browser is not supported by Teach Starter.

It is recommended that you use the latest version of Google Chrome, Mozilla Firefox or Safari to access Teach Starter.

Teach Starter supports:

  • Google Chrome
  • Mozilla Firefox
  • Safari

We do provide limited support for Microsoft Edge and limited legacy support for Internet Explorer 10 and above, however, we cannot guarantee that your experience will be 100% error free. We do not support Internet Explorer 9 or below.

If you are having issues accessing Teach Starter, downloading resources or viewing the website correctly, please try updating your web browser or downloading the latest version of our supported web browsers.

Download Google Chrome

Download Mozilla Firefox

If you would like to know what web browser you are using, please visit: http://www.whatsmybrowser.org/

Did this answer your question?